`
Dev|il
  • 浏览: 122219 次
  • 性别: Icon_minigender_1
  • 来自: 成都
社区版块
存档分类
最新评论

HDU2095

 
阅读更多
find your present (2)
Time Limit: 1000/2000 MS (Java/Others)    Memory Limit: 32768/1024 K (Java/Others)
Total Submission(s): 6923    Accepted Submission(s): 2548


Problem Description
In the new year party, everybody will get a "special present".Now it's your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present's card number will be the one that different from all the others, and you can assume that only one number appear odd times.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.


Input
The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<1000000, and n is odd) at first. Following that, n positive integers will be given in a line, all integers will smaller than 2^31. These numbers indicate the card numbers of the presents.n = 0 ends the input.


Output
For each case, output an integer in a line, which is the card number of your present.


Sample Input
5
1 1 3 2 2
3
1 2 1
0


Sample Output
3
2

HintHint
use scanf to avoid Time Limit Exceeded


Author
8600
#include <stdio.h>

//题意:就是找出其中个数为1的数
//算法思路:利用异或的性质
int main()
{
	int a, n, b;
	while(scanf("%d", &n), n)
	{
		a = 0;
		while(n--)
		{
			scanf("%d", &b);
			a ^= b;
		}
		printf("%d\n", a);
	}
	return 0;
}
分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics