`
Dev|il
  • 浏览: 121440 次
  • 性别: Icon_minigender_1
  • 来自: 成都
社区版块
存档分类
最新评论

HDU1097A hard puzzle

 
阅读更多
A hard puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13911    Accepted Submission(s): 4872


Problem Description
lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b's the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.



Input
There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)



Output
For each test case, you should output the a^b's last digit number.



Sample Input
7 66
8 800


Sample Output
9
6


Author
eddy

题意:求a^b结果的个位数是多少

#include <iostream>
using namespace std;
/*
分析:当a的个位是0 1 2 3 4 5 6 7 8 9时,只会出现一下循环,例如个位是2 那以后个位只会在2 4 8 6之间变动
0
1
2 4 8 6
3 9 7 1
4 6
5
6
7 9 3 1
8 4 2 6
9 1
*/
int cns[10][4] = {{0},{1}, {6, 2, 4, 8},{1, 3, 9, 7},{6, 4}, {5}, {6}, {1, 7, 9, 3}, {6, 8, 4, 2}, {1, 9}};
int main()
{
	int a, b, digit, cnt;
	while(cin>>a>>b)
	{
		digit = a % 10;
		switch(digit)
		{
		case 0:
		case 1:
		case 5:
		case 6:
			cout<<digit<<endl;
			continue;
			break;
		case 2:
		case 3:
		case 7:
		case 8:
			cnt = b % 4;
			break;
		case 4:
		case 9:
			cnt = b % 2;
			break;
		}
		cout<<cns[digit][cnt]<<endl;
	}
	return 0;
}


分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics